培训与教程


培训信息

服务器本机,登录时报错:connect to 127.0.0.1:7777 error, connection timed out 10060

问题分类:

系统配置

问题现象:

如题

发生环境:

问题原因:

可能的原因有:服务未启动,或Excel服务器默认的端口7777被其它的程序占用。

处理办法:

首先要检查服务是否已启动。如果在服务已启动的情况下,依然有上述报错,则按如下步骤去检查端口7777是否被别的程序占用了。

  1. 【开始】-【运行】,输入cmd,打开命令行窗口
  2. 输入命令 netstat -aon|findstr "7777",返回的结果是5列,分别是:协议、本地地址、外部地址、状态、PID
  3. 根据上一步显示出的结果,找到状态为“LISTENING”的那一行,查询其PID对应的是什么程序,做法是:
  4. 输入命令 tasklist|findstr "那个PID的值",观察返回的结果,假如返回结果中第一行第一列的内容不是“ES_Server.exe” ,则说明端口号7777被其它程序占用了,到系统管理台中用 系统参数设置功能,将默认端口改成其它的值,重新启动服务即可。

下面的图示,是上述步骤2~4执行命令的结果示意。首先执行了 netstat,看到状态是LISTENING的进程号是1936,接下来用 tasklist 命令去查进程 1936 对应的是哪个程序,发现就是 ES_Server.exe,即Excel服务器软件的服务程序。

检查勤哲Excel服务器默认端口是否被其它程序占用

参考资料: